Ferrari Life Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
my car was almost for 3 weeks standing at the airport in freezing temperature and when i came back, it didn't start, so i used another car to deliver power to my battery via starting cables ... when my engine started, i realised that all instuments/gauges and also aircon, heater nad fan is not working ... no speedo, revs, oil press ... nothing ;-/ ... i went through the manual and tried to check all fuses , but nothing found, everything seems to be o.k. ... i can drive the car , the main vital function remains unchanged ... can somebody give me the tip what it can be ??? does somebody have some electrical scheme of the car ?? ... thanks very much for any help !!!
 

·
Registered
Joined
·
2,211 Posts
That sounds pretty weird... Isn't it something with the dashboard? I don't think there is one cable that connects everthing that goes to the dashboard, but that is the only thing I can think of because that is the only thing that doesn't work. A friend of mine says it might be a relais problem. Maybe you can give the dealer a call, they can point you in a direction.
However, I'm not a technical person, but I'm sure some people here know some suggestions.
Welcome to the forum and I hope everything will be sorted out.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
thanks for help ... weird it is ... clima/AC is on the different circuit , than instruments ... both circuits has different fuses as i found in Owners manual, so it seems to me that problem is somewhere above ... still additional question: ... do you know where is the floor fuse/relay box ??? i have foun one box in the luggage compartment, but nothing on the floor or below ;-/ ... maybe there can be answer ;-) ... thanks very much , any help, suggestion welcomed
 

·
Administrator
Joined
·
15,140 Posts
The second fuse panel on the F355 is in the front of the passanger footwell. You access it by pulling the panel towards you. Per your description, it sounds like the electrical system spiked when you jump started the car. After you check all the fuses and relays, suggest you then reboot the engine management system. You can do this via cutting off the battery using the kill switch, turning the power back on, then starting the car with all electrical systems off (including the airconditioning)and letting it run in neutral on flat ground for 10 minutes. If this does not work, then you probably need to take it to a dealer.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
thanks for your help, i'm gonna to try find the second fuse box ... still additional Q. ... i know how to recognize burned fuse, but how can I recognize faulty relay ??? ... thanks
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
thanks to BOXER42 I've finally discovered the second fuse box below footwell and found two fuses no.24&25 burned out ... thank you very much for help and sorry for making too much noise ;-))) :green:
 
1 - 8 of 8 Posts
Top