Ferrari Life Forum banner

1 - 20 of 63 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
Hi everyone, Hate to beat a dead horse, but this oil filter thing has me stumped. Oil psi on start up getting slower, so I shut the car off and let it sit for 24 hours. Pulled off the fram filter I got from a ferrari dealer, not a drop in it. Let it sit mounting face up, looked in with a shop light no oil.
Dealers going to send a new one, any ideas??? Dan
 

·
Registered
Joined
·
286 Posts
Dan, First of all what is getting slower mean. How many secs. before the light goes off. Also did you cut the filter in half to check? I got to say that to be sure the Baldwin is the best filter. There was a problem with Fram standpipe filters having a problem bleeding off from a warped internal rubber washer under the standpipe. Just don't panic with a couple of secs. of the red light being on.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #3
Hi Magoo, thanks for the reply. On cold start up, I stare at the oil gauge a
good 4-41/2 secs. then it snaps to atten. about 85psi. It got worse from when I first changed it (the oil) But I cant see a drop in there(the filter) The dealer should have me a new one Wednesday afternoon, Ill try that. I put on my K&N to get me by, not much better. Dan
 

·
Registered
Joined
·
286 Posts
Dan, Are you looking at the guage or the light. I know that on my 308 the light goes out in about 2 secs on cold start up and the guage comes up about a couple of secs later. When the light goes out I know the pressure is building. Sometimes the guages don't react as quickly as the light. The needle can be sticking a bit. Try the new filter but I think it will be close or no change at all. Now if you were talking 10 or 15 secs. I could see cause for concern. JMO
 

·
Registered
Joined
·
36 Posts
Even the Baldwin filter leaks down on my car. If I let my car sit for 24 hours I can take the filter off and it is empty. No filter that I have ever used will hold oil 24 hours. It should but does not. I have used UFI, Baldwin and Fram and all do the same thing. My car takes about 3 to 4 seconds for the pressure to come up. The light goes out and the gauge moves about the same time.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #7
Thanks guys for the help. I think its the nature of the beast,and I (we)
will live with it. I think you are correct Edward about all filters leaking down after 24 hours. The oil leaks out the small holes and bleeds into the oil
cooler line, and into the sump in time. I'm taking that fram to the ferrari
dealer Monday, I'll post what they think on the forum. Magoo that light
stays on only a couple seconds, so I'm good there.Thanks again. Dan
 

·
Registered
Joined
·
133 Posts
I am running a mobil 1 on my 308 now. I will remove it and see if the oil remains in it. I too noticed that the frams bleed down. How long did car sit?
 

·
Registered
Joined
·
133 Posts
I am running a mobil 1 on my 308 now. I will remove it and see if the oil remains in it. I too noticed that the frams bleed down. How long did car sit?
 

·
Registered
Joined
·
133 Posts
my cars have ben sitting for over a week.I'll check them out 1 has a mobil 1 the others have baldwins.I'll let you know in day or 2.
 

·
Registered
Joined
·
133 Posts
Ok. The mobil 1 and the fram filter both bled done and where void of oil.I put the ufi back on my 308. I am going to let it sit till weekend.I'll let you know if it holds any oil.I am dissapointed about the mobil1.I knew the fram would eventually leak. Anybody know about the rumor that Ferrari approved of the Fram filters for use??????????????????
 

·
Registered
Joined
·
23 Posts
Discussion Starter #14
Hi Guys , I took the fram back to the Ferrai dealer, The parts Manager
told me this shouldn't happen. They gave me another but I think its doing the same thing. He also said he is getting a ton of complaints from other customers. He is trying to get some ufi's but said not to hold our breath.
Do we just live with it??? I'm not sharp on the oiling system on my 308
engine, Our we getting oil to the bearings and so forth ASAP?What do you
technicians think?? Dan
 

·
Registered
Joined
·
286 Posts
Dan, give us a count as to what longer is, by how many secs? Does the light go out before the guage comes up? Once it comes up what does the guage show on cold start and what does it show as the engine warms. If the light and guage are 8 to 10 secs or more before showing pressure then something is wrong and it probably isn't the filter. The next thing to do is check the pressure at the sending unit. If it is ok there and it comes up within the 4 sec. period of time you know it is ok and your elec. guage probably is the problem. If it is still a long period of time when you check with a guage at the sending unit then suspect other things such as the oil pump.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #16
Magoo, I'll start it up thurs. night, that will be about 48 hours I'll let you know. I'll check it with a watch to see if I'm in the ballpark. When it does
take off, I idle about 70/80 psi. so I am confident the motors healthy.
I blame the filter because this all started when I changed my oil a couple weeks ago, and removed the UFI filter. Dan
 

·
Registered
Joined
·
23 Posts
Discussion Starter #18
magoo, work schedule got me this week! I'll fire it up Sat. and post ASAP.Thank you for the response. Dan
 

·
Registered
Joined
·
133 Posts
Well I checke dthe UFI today. It is holding oil after 5 days. I dont think it is 100% full but oil is in it. I am seting it upside down on my garage floor to se how long it takes to bleed out. If at all. Will post update in week or sooner if it bleeds down sooner.
 

·
Registered
Joined
·
286 Posts
Bruno, You mentioned about Ferrari approving Fram oil filters. In your owners manual Ferrari reccommends the Fram oil filter.
 
1 - 20 of 63 Posts
Top