Ferrari Life Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi all,
2 Days ago I finally bought my first Ferrari. Im 34 and its taken since I was 6 years old gazing at the picture on my bedroom wall. Im sooo excited. My dad has owned 3 x 348s and though I couldnt quite afford the same Im delighted to own a Mondial T with the same engine and gorgeous F355 alloys.

The radio and the air-con didnt work from the outset (just hot air) but I was just into my 1st days driving and the indicators stopped working along with the electric windows. The whole dash cluster including the speedo/ odometer were suddenly dead too. Lights work but brake lights dont.

I had to get the car back to dry storage (with the windows wide open and British weather being so temperamental) so I carefully drove to my garage in twilight, with my lights on for the first time. Half way along the 6 mile jouney she conked out having lost power. I tried to restart her but the battery was almost dead. Fortunately I keep a jump pack in the car and hard wired it to the battery and she burst into life to get me home safely (at this point I noticed the cooling fans werent turning on either)

2 x 20 amp fuses were blown so changed but no visible changes. Anybody any ideas please? I read on FL forum that GT4s had awful Fuse boxes and theyre better overhauled or replaced. Is this the same for the Mondial T?
Could there be a Master fuse that controls lots of electrics? Any suggestions gratefully received.

By the way - Im not even slightly put off owning this treasure. Im still really excited by the look, the feel and the unique Ferrari smell. Cant wait to get behind the wheel again!
Kind regards from a newbie.
Jerry
 

·
Registered
Joined
·
6,209 Posts
Hi all,
2 Days ago I finally bought my first Ferrari. Im 34 and its taken since I was 6 years old gazing at the picture on my bedroom wall. Im sooo excited. My dad has owned 3 x 348s and though I couldnt quite afford the same Im delighted to own a Mondial T with the same engine and gorgeous F355 alloys.

The radio and the air-con didnt work from the outset (just hot air) but I was just into my 1st days driving and the indicators stopped working along with the electric windows. The whole dash cluster including the speedo/ odometer were suddenly dead too. Lights work but brake lights dont.

I had to get the car back to dry storage (with the windows wide open and British weather being so temperamental) so I carefully drove to my garage in twilight, with my lights on for the first time. Half way along the 6 mile jouney she conked out having lost power. I tried to restart her but the battery was almost dead. Fortunately I keep a jump pack in the car and hard wired it to the battery and she burst into life to get me home safely (at this point I noticed the cooling fans werent turning on either)

2 x 20 amp fuses were blown so changed but no visible changes. Anybody any ideas please? I read on FL forum that GT4s had awful Fuse boxes and theyre better overhauled or replaced. Is this the same for the Mondial T?
Could there be a Master fuse that controls lots of electrics? Any suggestions gratefully received.

By the way - Im not even slightly put off owning this treasure. Im still really excited by the look, the feel and the unique Ferrari smell. Cant wait to get behind the wheel again!
Kind regards from a newbie.
Jerry

348/ Mondial T had known issues with the fuse block/box. Check the area immediately near the wire plug in section to the right as you look fwd. IF there are any burns, or warpage on the rear of the box, you need to address it NOW. Either replace it or have a pro resolder all its layers. The difficult part is the actual wire plugins: you'll have to remfgr your own and live with that or try to find NOS. PS: This is NOT an issue to put off.

rik
 
1 - 2 of 2 Posts
Top