Ferrari Life Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
52 Posts
Discussion Starter #1
Yesterday while driving my 2012 FF switched from sport mode to Wet;

Displaying the following errors

"Low 4WD ATF oil pressure"
"Manettino failure"
"4WD system failure"
"Go to dealer"

Today it’s just listing low 4wd atf oil pressure.

Drives fine, no issue. Was hoping a reset would take care if it. This morning same thing 5-10 min into the drive it switched from sport mode to wet with low 4wd atf oil pressure message.

Have you come across this, it’s my daily driver so not sure if it could be the battery as I read similar issues on the Ferrari forums and they found changing battery took care of it.

I’m a ways from the closest dealer; scheduled 6 year service is June 26th. Is it ok to drive, like I said I sense no changes in performance.

Or is there a way to manually check the 4wd atf oil and add some if need be?

Thanks as always in advance

Izzy
 

·
Registered
Joined
·
967 Posts
This is not a battery issue.
This system has low pressure, likely due to low fluid level.
When this condition occurs, typically the AWD system will disengage the front wheels to prevent (further) damage. Although the car may drive "fine" the is a possibility of damage to the front differential.

Not worth it to guess... A hands-on, local diagnosis is needed. Off to the dealer would be my advice.
 

·
Registered
Joined
·
52 Posts
Discussion Starter #3
Thanks David; I'll put her in the garage and wait till the 26th to driver her up to Toronto. Nearest dealership to Rochester, NY. Is there a way to manually check and if need be add some fluid so when I make the 3.5 hour drive to Toronto I can be on the safe side?
 

·
Registered
Joined
·
6,207 Posts
Shouldn't you have the car carried to Toronto?
 

·
Registered
Joined
·
1 Posts
Hello,
I also daily my 2014 FF (maybe a little too hard) and this morning when I started the car it was stuck in WET with the same warnings as yours.. I also live really far from the nearest dealership in the country 😞

Did the dealership tell you what is wrong with it? Were they able to fix it?
Hope to hear from your! Best Regards
Giovanni
 

·
Registered
Joined
·
2 Posts
Hello,
I also daily my 2014 FF (maybe a little too hard) and this morning when I started the car it was stuck in WET with the same warnings as yours.. I also live really far from the nearest dealership in the country 😞

Did the dealership tell you what is wrong with it? Were they able to fix it?
Hope to hear from your! Best Regards
Giovanni
Hi Giovanni,

appreciate this post dates back sometime now, but can I ask how did it end up with your FF 4WD failure?

Many thanks!
Marco
 

·
Registered
Joined
·
2 Posts
Hello everyone,

Has anyone experienced similar problems? And how did you address it?
I’m wondering whether to extend my warranty or not and this issue on PTUs may be a good reason to do so!

Many thanks
 
1 - 7 of 7 Posts
Top