Ferrari Life Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2,112 Posts
Discussion Starter #1
Ciao All Well today it happened I got stung finaly???????$hite????????

I was leaving my club tonight for home luckily it is only 4 blocks away the first 3 blocks went fine no worries then the last block I felt something a little strange when I depressed the clutch couldn't figure out what exactly then I go to up shift and OMG no clutch at all just a mushy pedal. I was able to coast close to home and my neighbor helped me push the car in.

From behind the car there is lubricant leaks light green in color????? I assume that I just blew a hose for the hydraulic clutch or a slave clutch but I need your expert opinion.

I have not looked for the leak as of yet since it is late I will tomorrow but the puddle is directly under the clutch housing but the lubricant might be running down from another location.

Gentlemen any ideas?
 

·
Registered
Joined
·
2,112 Posts
Discussion Starter #3
Well we figured the problem being the slave cylinder and Daniel from Ricambi was gracious to help me out hell of a man that Daniel.
 

·
Registered
Joined
·
3,874 Posts
Well we figured the problem being the slave cylinder and Daniel from Ricambi was gracious to help me out hell of a man that Daniel.
Good to hear. Hopefully it wasn't to painful on your wallet.

Chris
 

·
Registered
Joined
·
2,112 Posts
Discussion Starter #5
Well all is good with my baby parts were installed with a beefier 355 slave cylinder and housing cost a bit more but that failure will never happen again.

All in all around $1900 start to finish including shipping labour and parts.
 
1 - 5 of 5 Posts
Top