Ferrari Life Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
can anyone please help.car not starting. i switched off battery cut off switch. switched it back on ten mins later. tried to start car. have no ignition lights, only abs lights for few seconds. park lights,windows,stereo working. car does not turn over. checked fuses under bonnet and inside car. swapped relay's, no luck. tried resetting alarm few times-nothing. ANY IDEA'S REALLY APPRECIATED.
 

·
Registered
Joined
·
473 Posts
mitch said:
can anyone please help.car not starting. i switched off battery cut off switch. switched it back on ten mins later. tried to start car. have no ignition lights, only abs lights for few seconds. park lights,windows,stereo working. car does not turn over. checked fuses under bonnet and inside car. swapped relay's, no luck. tried resetting alarm few times-nothing. ANY IDEA'S REALLY APPRECIATED.
Sounds like the battery is really low, have you tried recharging the battery or using a flat battery starter? I've had this happen several times on my old 355 as I used to run the car infrequently (Once a month), often some accessories (radio etc) will work but the starter motor will still not turn over.

Derm
 

·
Premium Member
Joined
·
5,509 Posts
Yeah, you'll have to put a volt meter on the battery and check that out. You'll need a buddy to help you check it out. Put a voltmeter on the battery while your friend hits the key. If the battery reads 12.5 normal and goes below 10.5 while trying to crank then the battery is no good. The other thing it could be is a bad connection. If the battery reads 12.5 while the key is in the start position and it doesn't turn over then it is probably a bad connection somewhere. I once had a car that was running, quit and would not restart due to a bad battery connection. Do the operating accesseries stop when you are trying to crank the motor? Be sure all of your connections are clean and tight. Don't forget the ground connections, they are just as important.

It could be the battery cut off switch itself also. Did the car start normally before you switched off the battery? Is it possible to bypass or "jump" the switch to check that? I don't know how hard it is to get to the back off the switch (I imagine its not easy). Put your voltmeter on both of those connections to check voltage drop across the switch. It should not be more than 0.2.

Worst case scenario - the starter crapped out on you. If you have 12 volts at the starter and it won't crank (assuming the engine is free) then it is the starter.

Let us know how you make out. I'm hoping its the battery. Those are easy and relatively cheap to replace.
 

·
Registered
Joined
·
1,684 Posts
Sounds like it's the battery. You have to change it. Once the battery is flat, I find that it will be drained very quickly. The battery is in the space between the right front wheel arch and the bumper. You have to remove the right front tyre and the dirt shield to access the battery.

Good luck.
 
1 - 4 of 4 Posts
Top