Ferrari Life Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
60 Posts
Discussion Starter #1
Hello everyone,
I'm still working on the restoration of my 308 GTB 1979 drysump and I have one more question for you... My speedometer indicate the speed but not counting the kilometers (I'm in Europe), it stays at 85000 km but sometime it come up a little bit, for example, I did recently 1000km in one time and at the end, the meter indicate 8 km more. Is it a problem with the sensor or is it a problem with the speedometer itself, I checked all the cable behind are well and clean connected, the button to clear the trip kilometer are working well too. (the sensor indicate very well the speed and haven't been changed). Please give me your advice if someone did have the same problem (it's only my second Ferrari and the other one was a 330 but already fully restored). There's also, if it could help, when I turn the ignition, all the light (generator and oil) turn on and at the same time the hand of the speedometer make a quick small jump... Thank you very much for your help.
Jephma
 

·
Premium Member
Joined
·
5,509 Posts
If it is indicating the speed then it is not the sensor. Sounds like it is the speedometer itself.
In the US, Palo Alto speedometer repair is the place to send your gauges. Here's the link:http://www.paspeedo.com/
I'm sure there is a similar place in France or somewhere else in Europe.
 

·
Registered
Joined
·
60 Posts
Discussion Starter #3
Thank you very much

Hi Pete,
Thanks for your answer, I contact them and it seems to be easy to repair, I just have to send it to them. Maybe there's one in Europe but when you send something, distance doesn't really count so... as they look very serious and it's not expensive to repair, I will do it. Thank you again...
Jephma:)
 
1 - 3 of 3 Posts
Top