Ferrari Life Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Anyone ever notice a loss in torque ina Testarossa, but while car operates normally? IT will pull through the gears most smoothly, but every once in a while, a "seat of your pants" torque loss occurs that is noticeable when power pedaling throught the gears. Then, for no explained reason, it will disappear and the car will appear to run normal with full torque and power.
I've put injector cleaner in thinking that was it; there are new plugs in the car (Jan 08), and it starts and idles properly with proper timing and idle on tach.
Also, I run Shell high test. I'm wndering if fuel quality may be an issue?

Anyone ever experience this? Wondering what it might be....
[email protected] is my personal email address with any ideas you might have...Thanks in advance!

Bill in Florida
 

·
Registered
Joined
·
11 Posts
Discussion Starter #2
Anyone ever notice a loss in torque ina Testarossa, but while car operates normally? IT will pull through the gears most smoothly, but every once in a while, a "seat of your pants" torque loss occurs that is noticeable when power pedaling throught the gears. Then, for no explained reason, it will disappear and the car will appear to run normal with full torque and power.
I've put injector cleaner in thinking that was it; there are new plugs in the car (Jan 08), and it starts and idles properly with proper timing and idle on tach.
Also, I run Shell high test. I'm wndering if fuel quality may be an issue?

Anyone ever experience this? Wondering what it might be....

Bill in Florida
I figured out the issue. Bad fuel pump relay!! Yeah!!
Thanks for the views.
 

·
Registered
Joined
·
308 Posts
I detect a hint of sarcasm in your last post. Never the less...I'm glad you found the problem. Often times.....when a condition is intermittent....it is electrical component related. Testarossas benefit from a periodic electrical connection disconnect/reconnect. There are a lot of items in the loop that must function properly for a TR to run "right". Common issues are the circuits for the fuel pumps and cooling fans....you have to watch out for burned connectors at the mother board. Many owners re-wire these circuits and bypass the weak factory connectors at the mother board. All things considered....the Testarossa can be a very reliable car if properly maintained.
 
1 - 3 of 3 Posts
Top