F355 355 F1 Fuses and Relay not listed in manual or WSM - Ferrari Life
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 09-05-2015, 05:23 PM Thread Starter
Owner
 
dave rocks's Avatar
 
Join Date: Nov 2012
Location: Orchard Park, New York
Ferrari Life Posts: 1,875
Garage
355 F1 Fuses and Relay not listed in manual or WSM

Big thanks to Grant for tipping me of in this thread:

http://www.ferrarilife.com/forums/pr...f1-failed.html

I started this new thread so folks could find it easily.

Behind the passenger foot rest (lower right corner) 2 addition fuses and 1 relay are for the F1 system. From a brief scan of the owners manual and WSM, I do not see these listed. But, I may just have missed it....

The 2 fuses are larger Maxi Blade fuses. One is a 20 amp and the other is a 40 amp.

The relay is common with others used in the car, it's Bosch 0 332 019 103
Attached Images
 
dave rocks is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 09-05-2015, 05:24 PM Thread Starter
Owner
 
dave rocks's Avatar
 
Join Date: Nov 2012
Location: Orchard Park, New York
Ferrari Life Posts: 1,875
Garage
dave rocks is offline  
post #3 of 6 Old 09-05-2015, 05:25 PM Thread Starter
Owner
 
dave rocks's Avatar
 
Join Date: Nov 2012
Location: Orchard Park, New York
Ferrari Life Posts: 1,875
Garage
dave rocks is offline  
 
post #4 of 6 Old 09-05-2015, 05:26 PM Thread Starter
Owner
 
dave rocks's Avatar
 
Join Date: Nov 2012
Location: Orchard Park, New York
Ferrari Life Posts: 1,875
Garage
dave rocks is offline  
post #5 of 6 Old 09-10-2015, 09:38 PM
Owner
 
Taz355's Avatar
 
Join Date: Mar 2013
Location: Alberta,california
Ferrari Life Posts: 379
You got it Dave the other thing that should be mentioned is the plug to the F1 pump at the back can also be an issue. If the fuse goes itmcan also be the plug as the issue not the f1 pump. What i did to find it was i turned the key to position 1 and the f1 pump did not kick in.
Then i went to the back and wiggled the plug and instantly the pump came to life. I used the gold connector kit tools to remove the two connectors and replaced them with crimp connectors which were identicle for our kenworth truck gauges. No problems since.
Taz355 is offline  
post #6 of 6 Old 09-10-2015, 09:40 PM
Owner
 
Taz355's Avatar
 
Join Date: Mar 2013
Location: Alberta,california
Ferrari Life Posts: 379
Here is a pic of the plug.
Attached Images
 
Taz355 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
Copyright 2012 ONE Media, Inc.
FerrariLife is independently run with no affiliation with Ferrari SpA
Ferrari for Sale | Maserati for Sale