328 Magic fuel pump fault - Ferrari Life
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 04-28-2014, 09:36 PM Thread Starter
Owner
 
mehl's Avatar
 
Join Date: Feb 2011
Location: Bad Dürkheim
Ferrari Life Posts: 64
Magic fuel pump fault

Dear All, does anyone have an idea on this:

Car starts vey well aftrer very few cranks - hot and cold.
If you turn it off and want to turn it on again obviously the fuel pump is not switched on and I cant start the engine. This can last for a few minutes to several hous. Then again: Everythng fine, immediate start, after very few cranks. This happens with cold & hot engine.

On non faulty start I hear a well hearable "clonk" from the engine compartement like a big relay activated. Then I hear the whining noise from the fuel pump.

Is there a fuel pressure check switch stuck somewhere? Where ist it?
Is the fuel pump close to its end?

Help please!

Christian
mehl is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 04-29-2014, 08:04 PM
Owner
 
barcheta's Avatar
 
Join Date: Mar 2004
Location: Maryland
Ferrari Life Posts: 1,875
Looks as if you got lots of input from the other site. Check that fuel accumulator.

Current: 85' GTS QV
It's a simple process...... it's just complicated by human beings....
barcheta is offline  
post #3 of 5 Old 04-30-2014, 09:28 PM
Owner
 
KKRace's Avatar
 
Join Date: Nov 2009
Location: Near Olney, MD
Ferrari Life Posts: 1,354
I put up a bunch of diagnostic info on this a while back. http://www.ferrarilife.com/forums/pr...l-pump-no.html

------------------------------

Life is Good!
KKRace is offline  
 
post #4 of 5 Old 05-19-2014, 03:36 AM Thread Starter
Owner
 
mehl's Avatar
 
Join Date: Feb 2011
Location: Bad Dürkheim
Ferrari Life Posts: 64
Thank you Kevin! Life is much better with good hints from the internet. It was exactly the connector behind that flap on the co drivers floor as pictured in #7 in your thread.

The short delay on the start of the fuel pump was obviously the time until the corroded connection pin heated up and gave good enough contact. No delay now, fuel pump is immediate on with ignition.

Thank you again , I'm very happy now.
Christian
mehl is offline  
post #5 of 5 Old 05-22-2014, 10:33 AM
Owner
 
KKRace's Avatar
 
Join Date: Nov 2009
Location: Near Olney, MD
Ferrari Life Posts: 1,354
Quote:
Originally Posted by mehl View Post
Thank you Kevin! Life is much better with good hints from the internet. It was exactly the connector behind that flap on the co drivers floor as pictured in #7 in your thread.

The short delay on the start of the fuel pump was obviously the time until the corroded connection pin heated up and gave good enough contact. No delay now, fuel pump is immediate on with ignition.

Thank you again , I'm very happy now.
Christian
Glad to be of help. Others helped me so I felt I should pay it forward and combine the info into one place.

------------------------------

Life is Good!
KKRace is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
Copyright 2012 ONE Media, Inc.
FerrariLife is independently run with no affiliation with Ferrari SpA
Ferrari for Sale | Maserati for Sale