F430 help 430 indicators not working - Ferrari Life
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 05-10-2014, 09:21 AM Thread Starter
 
Join Date: May 2014
Ferrari Life Posts: 2
help 430 indicators not working

had car out today and indicators are not working

checked fuses under the bonnet cant see any blown but not sure if looking at correct ones!
hazards work but no indicators left or right
any ideas????
430sh is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 05-10-2014, 02:31 PM
Owner
Elite Member
 
tazandjan's Avatar
 
Join Date: Aug 2011
Location: Albuquerque, NM
Ferrari Life Posts: 11,858
Welcome to Ferrari Life. Turn signal indicators?

Taz
Terry Phillips

Present: 575M 135171
Past: Dino 246 GT 02984, 365 GTB/4 14009, 308 GTS 25125

Every day I look around, and if nobody is shooting at me, it is a pretty good day.
tazandjan is online now  
post #3 of 7 Old 05-10-2014, 06:28 PM
Owner
 
netman's Avatar
 
Join Date: Jun 2008
Location: SoCal
Ferrari Life Posts: 226
Garage
Check the flasher relay.
netman is offline  
 
post #4 of 7 Old 05-11-2014, 03:37 AM
Owner
 
StefVan's Avatar
 
Join Date: Sep 2007
Location: Switzerland
Ferrari Life Posts: 2,340
Welcome the FerrariLife The F430 has a specific ECU to manage the turn signal lights. The ECU is located under the dashboard at the passenger side. It is protected by a 15 Amp fuse AF17. This fuse is located in the front luggage compartment as show on this picture.

Name:  IMG_2652R2.jpg
Views: 1667
Size:  42.2 KB

Make sure this fuse is fine which should be if your hazards are still working, but better check it.

Any chance you changed something on your turn signal lights? Maybe LEDs? Some cheap LED's WILL break this ECU on the F430, I can unfortunately warranty that. This ECU is very different from the usual flasher relay as it contains several fragile IC's. I just hope this isn't your case.

The other thing you can also check is the steering column switch. There are 4 large connectors and 2 are partly used for the turn signal lights. Make sure that these connectors are correctly connected.

Let us know how it goes
StefVan is online now  
post #5 of 7 Old 05-11-2014, 04:24 AM Thread Starter
 
Join Date: May 2014
Ferrari Life Posts: 2
thanks for info! checked fuse its fine, nothing changed bulb wise, it worked on the way to the shop just not on eay home, I did notice the radio had not gone off when I returned to the car?
if press the hazards can hear the relay clicking behind glove box
430sh is offline  
post #6 of 7 Old 05-11-2014, 11:45 AM
Owner
 
StefVan's Avatar
 
Join Date: Sep 2007
Location: Switzerland
Ferrari Life Posts: 2,340
Any chance your car has been jump started? There is indeed a small relay in the ECU, that's what you hear. You're saying that the hazards do work normally?

Last edited by StefVan; 05-11-2014 at 12:34 PM.
StefVan is online now  
post #7 of 7 Old 05-12-2014, 11:50 AM
Owner
 
Granucci's Avatar
 
Join Date: Jan 2007
Location: far and away
Ferrari Life Posts: 6,196
try swapping relays

Guide to the Galaxy: Don't Panic
Rik -- LAH !


Current:
Past:
1990 Mondial T Cabriolet SN 86247 : Red/Tan
1995 456 GT 2+2 SN 99987 : Roso Metalizzato [Fer 311/C] & Tan
Granucci is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
Copyright 2012 ONE Media, Inc.
FerrariLife is independently run with no affiliation with Ferrari SpA
Ferrari for Sale | Maserati for Sale