F430 05 F430 F1 CEL coming on! - Ferrari Life
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 04-25-2012, 08:23 AM Thread Starter
 
Join Date: Dec 2011
Location: Richmond, VA. USA
Ferrari Life Posts: 7
05 F430 F1 CEL coming on!

Hi Fellows, I have this intermittent problem of the CEL coming on for about a year now. It can pop on just about anytime and also go off on its own. Car runs great! I was finally able to catch it on and hookup my Autotron analyzer. It displayed "manufacturer power train P1302" code. I checked the list posted by StefVan, but don't see that one listed? Another bit of history, I overfilled the oil by just a little a year ago and that's when this started (stupid me!). Maybe that will give someone a hint for me? Thanks for any help, Bob
Badbob1 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 04-25-2012, 08:52 AM
Owner
 
StefVan's Avatar
 
Join Date: Sep 2007
Location: Switzerland
Ferrari Life Posts: 2,353
Hi Bob, you're not the only one who overfilled with engine oil P1302 can be related to the MAF. Once you've overfilled it, your MAF's will get very dirty as oil will be redirected towards the intake. I would suggest you check your MAF sensors first and make a good cleaning of the entire intakes.

Can you post the freeze frames from your diagnostic tool?

Last edited by StefVan; 04-25-2012 at 08:58 AM.
StefVan is online now  
post #3 of 5 Old 04-25-2012, 01:09 PM Thread Starter
 
Join Date: Dec 2011
Location: Richmond, VA. USA
Ferrari Life Posts: 7
Thanks a Bunch!

Thanks Stefvan, I knew you would come through. I' ll open it up and give it a good cleaning with the appropriate spray. Any additional words of caution or wisdom for this cleaning operation? Unfortunately I cleared the code and reset the light, so I can't post it for you. I did drive the car a bit today and no CEL this time. Thanks for you help as always, Bob
Badbob1 is offline  
 
post #4 of 5 Old 04-26-2012, 07:48 AM
Owner
 
StefVan's Avatar
 
Join Date: Sep 2007
Location: Switzerland
Ferrari Life Posts: 2,353
You're welcome Bob.

To clean the MAF's, try first using alcohol on a cue tip. Be very carefull not to damage the thin film on the sensor. If you can't get away the dirt, don't insist and use a contact cleaner. Dry the MAF with compressed air only BEFORE installing it again. As for the intake ducts, you can use any soft degreaser to get rid of the oil. Rince with care so that no product is left and dry with compressed air. Double check that absolutely no objects or dust is left in the duct. While cleaning the intake ducts, protect the plenum with clean clothes so that nothing can get inside, not even a fly or sand grain. After everything is re-installed, cycle off the main power switch and leave it off overnight (don't close the driver's door and front bonnet ) The day after, make a full relearn procedure and lets hope that all will be fine now
StefVan is online now  
post #5 of 5 Old 04-26-2012, 12:48 PM Thread Starter
 
Join Date: Dec 2011
Location: Richmond, VA. USA
Ferrari Life Posts: 7
Got my weekend choir lined up!

Thanks for your wisdom, I'll keep it sanitary as a hospital OR!
Regards, Bob
Badbob1 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
Copyright 2012 ONE Media, Inc.
FerrariLife is independently run with no affiliation with Ferrari SpA
Ferrari for Sale | Maserati for Sale