New problem, PLEASE HELP!! 308GTSi fuel pump failure - Ferrari Life
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 05-20-2003, 12:14 PM Thread Starter
Owner
 
Tifosi's Avatar
 
Join Date: Apr 2003
Ferrari Life Posts: 62
New problem, PLEASE HELP!! 308GTSi fuel pump failure

Well, I finally picked up my "new" 308 this weekend! Finally my first Ferrari! Drove it home, and nearly made it all the way, made it 850 miles out of the 1100, but found that it had a gasoline leak. Was able to get it to a garage and up in the air high enough to check it out in greater detail, found that after tightening the pump inlet hose clamp and checking the other fittings, that he pump itself was leaking, not a lot but more than I wanted to even attempt to drive it. The last thing I needed was burn my new Ferrari to the ground! I have a new pump on order, should be able to replace it this weekend. Now for my questions, is this a common failure? The pump doesn't seem to be very heavy duty, or that special for that matter, what brand is it? What pressure does it run at? Is there any other "common" pump that would cross up with it? And last, any tips on the replacement work? Thanks much

Tifosi
1980 Ferrari 308 GTSi
2002 Mercedes Benz C32 AMG
2004 Triumph Bonneville - Cafe Racer
Tifosi is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 05-23-2003, 08:01 AM
Owner
 
Join Date: Aug 2002
Ferrari Life Posts: 133
They are not much to look at. I think the pressure is 5.5 but dont hold me to it it has been a while. Also do not buy a replacement from superformance. I got one from them . They use FACET. It fit and worked perfectly but it was louder than loud. How LOUD u ask. I had to take it off. You can call maybe they use a better pump now. If not get an original pump. It'll cost too much but problem solved. I can look around for the facet pump I got. If I find it I'll let you know.
BRUNO is offline  
post #3 of 3 Old 05-24-2003, 01:21 PM Thread Starter
Owner
 
Tifosi's Avatar
 
Join Date: Apr 2003
Ferrari Life Posts: 62
Well the pump is changed and the leak is gone, which is great, but now the car is hard to start when warm, not so great... I know the PO had the accumulator changed not more than 6-8 months ago, so I don't think that that is the problem. Could it be due to the "tuning" of the FI system? The filters have not been replaced, so maybe the process of changing the pump and the new pump it self has caused the filters to clog up a bit??? I really don't know because once it is started it runs great, so I'm a bit confused by it all. I had a FI'ed Porsche with a similar Bosch FI system and it was a real pain to tune/set, it also had warm starting issues, but with enough fiddling around with the FI I seem to have made it better. Any help with warm-starting fixes would be great, Thanks again...

BTW I'm going to to attempt to post a picture of her in the Garage Formum for you all to check out - Thanks...

Tifosi
1980 Ferrari 308 GTSi
2002 Mercedes Benz C32 AMG
2004 Triumph Bonneville - Cafe Racer
Tifosi is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
Copyright 2012 ONE Media, Inc.
FerrariLife is independently run with no affiliation with Ferrari SpA
Ferrari for Sale | Maserati for Sale