Rough idle and some hesitation in TR - Ferrari Life
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 07-20-2007, 07:00 AM Thread Starter
Owner
 
Join Date: Jan 2007
Location: Edmonton, Alberta, Canada
Ferrari Life Posts: 31
Rough idle and some hesitation in TR

Hi.

My recently acquired 1991 Testarossa is starting to idle a bit rough, and lags a bit at lower revs. The problem seems to be constant, though perhaps a bit more pronounced when the car is warm. No other symptoms (oil is clean, rads are good, etc.) At higher revs, the engine is strong.

Any suggestions? I immediately thought electrical, plugs and wires maybe, but haven't gone any further.

Thanks in advance.
Canuckcarguy is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 07-20-2007, 08:08 AM
Owner
 
Join Date: May 2007
Ferrari Life Posts: 167
probably injectors that is the problem I had with my 89 luckily the K-Jet mech injectors are cheap
the head is offline  
post #3 of 5 Old 07-20-2007, 04:49 PM
Owner
Elite Member
 
Pete04222's Avatar
 
Join Date: Jun 2002
Location: USA & Singapore
Ferrari Life Posts: 5,509
Have you pulled any of the plugs out to look at them? Getting worse when warm does point towards electrical. I'd yank those plugs out and give them a look over, check the wires for a high resistance or cracks in the insulation, and fill it up with premium and run a can of injector cleaner through it.

Capt. Pete
'79 308 GTS, '82 Jeep CJ7 Jamboree
"Time is what prevents everything from happening all at once."
Pete04222 is offline  
 
post #4 of 5 Old 07-21-2007, 09:22 AM Thread Starter
Owner
 
Join Date: Jan 2007
Location: Edmonton, Alberta, Canada
Ferrari Life Posts: 31
Quote:
Originally Posted by Pete04222 View Post
Have you pulled any of the plugs out to look at them? Getting worse when warm does point towards electrical. I'd yank those plugs out and give them a look over, check the wires for a high resistance or cracks in the insulation, and fill it up with premium and run a can of injector cleaner through it.
That sounds like a good place to start, I'm going to try that tomorrow. Our days are long here, so during the week I couldn't get the garage dark enough to look for sparks, but I'll try the plugs tomorrow.

It's Grand Prix weekend here, lots of Ferraris and other exotics are sneaking out of their hiding places and hitting the road, so I won't start pulling apart until the end of the weekend.

Thanks, I'll post updates.

M
Canuckcarguy is offline  
post #5 of 5 Old 07-23-2007, 04:56 PM
 
Join Date: Jul 2007
Ferrari Life Posts: 5
I had the same poblem on a testarossa I found the temp sensor to be bad. Know the car has a low idle can any one help? Didn't mean to highjack this thread. i apoligize
pmpnuss is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
Copyright 2012 ONE Media, Inc.
FerrariLife is independently run with no affiliation with Ferrari SpA
Ferrari for Sale | Maserati for Sale