360 Manual 360 Modena won't rev in neutral... - Ferrari Life
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 02-12-2017, 01:07 PM Thread Starter
 
Join Date: Mar 2009
Ferrari Life Posts: 3
Manual 360 Modena won't rev in neutral...

I have been experiencing a weird problem with my Ferrari 360 Modena manual gearbox.
When I drive the car, when I shift to neutral and coast the car, if I press the gas pedal the engine initially won't rev, but there will be small explosions in the exhaust, like unburnt fuel, and then it will rev.. very weird and annoying problem especially when trying to rev match a downshift...

Here are some videos of the problem "manual 360 won't rev when rolling" that I took today... (standard OEM exhaust)

First is the startup : Engine Starts with Strong Idle... At some point (0:22) the exhaust valves close and there is some rattle (no problem here, just a little annoying) and continues with healthy idle...


--------------------------------------------------------------------------------------------

Next is the idle : As the engine continues to idle, the idle sound appears to have breaks, work intermittently... Instead of normal vrooooooooooooo , it appears to be vroo vroo vroo vroo ... As if one side or both sides of the V8 are not working properly. Open or closed exhaust valves do not change this intermittent problem...


----------------------------------------------------------------------------------------------

And now the problem : As I start to drive the car in 1st gear, I put neutral (0:12) and as I coast I rev the engine... You can see the RPM not rising immediately (lagging) and there are some exhaust explosions (seems like unburnt fuel in the exhaust)... Very strange and annoying, especially if you are downshifting and want to double declutch / rev match...


--------------------------------------------------------------------------------------------

The car is rolling in neutral, as I try to floor the engine and rev it, again there are exhaust explosions and popping...


--------------------------------------------------------------------------------------------

Same problem again, car rolling in neutral, exhaust popping (these are not the exhaust valves opening) when trying to rev the engine...


----

I have done the following things : fixed timing 100% with degree wheel and dial indicators based on WSM. Changed intake manifold gaskets. Changed MAFs. Changed Oxygen sensors. Changed ignition coils and spark plugs. Measured fuel pressure ok. Checked cylinder compression ok. Now what?
md355 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 02-20-2017, 08:47 AM
Owner
Elite Member
 
t1fosI's Avatar
 
Join Date: Apr 2007
Location: London, UK.
Ferrari Life Posts: 1,735
I had a similar problem with my 360 a couple of years ago (poor idle, fuel smell and no response from throttle when pressed). It was diagnosed as the Motronic ECU for the left bank of cylinders iirc. Roughly GBP1500 each ECU and sold only as pair. The ECU is made by Bosch but only available from factory via dealer. I checked with Bosch UK, they had them in stock but would only supply to factory direct, so it went from the UK to Italy, then back to the UK and to the dealer. Used ECU doesn't work because the ECU is supplied blank and the vehicle data is burned on to it upon installation. Car runs sweet-as now

The initial diagnostic was also showing a problem with MAF sensors but they were fine. I suspect the erratic idle triggered multiple superfluous codes.
t1fosI is offline  
post #3 of 4 Old 02-20-2017, 10:25 AM
 
Join Date: Jul 2016
Ferrari Life Posts: 18
Quote:
Originally Posted by t1fosI View Post
I had a similar problem with my 360 a couple of years ago (poor idle, fuel smell and no response from throttle when pressed). It was diagnosed as the Motronic ECU for the left bank of cylinders iirc. Roughly GBP1500 each ECU and sold only as pair. The ECU is made by Bosch but only available from factory via dealer. I checked with Bosch UK, they had them in stock but would only supply to factory direct, so it went from the UK to Italy, then back to the UK and to the dealer. Used ECU doesn't work because the ECU is supplied blank and the vehicle data is burned on to it upon installation. Car runs sweet-as now

The initial diagnostic was also showing a problem with MAF sensors but they were fine. I suspect the erratic idle triggered multiple superfluous codes.
How much budget to repair it?
sepatubutut is offline  
 
post #4 of 4 Old 02-20-2017, 03:06 PM
Owner
Elite Member
 
t1fosI's Avatar
 
Join Date: Apr 2007
Location: London, UK.
Ferrari Life Posts: 1,735
Quote:
Originally Posted by sepatubutut View Post
How much budget to repair it?

Tbh I can't remember the exact amount, it was a couple of years ago. The dealer I use is superb and always looks after me really well so I was happy with the outcome.
t1fosI is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
Copyright 2012 ONE Media, Inc.
FerrariLife is independently run with no affiliation with Ferrari SpA
Ferrari for Sale | Maserati for Sale